Cloud Telephony Admin Portal - Manage Phone Users
Incident Report for LoopUp
Resolved
This incident has been resolved. Replication times for adding and removing users are back to normal. If you experience any other issues, please contact us at support@loopup.com.
Posted Apr 05, 2023 - 19:11 UTC
Investigating
We are currently experiencing delays when adding and removing users in our admin portal.

As a result, it may take longer than usual for your request to replicate. Please allow up to 24 hours as standard.

We're sorry to be holding you up. If you've any questions, our Support Team are available 24/7 at support@loopup.com.
Posted Apr 05, 2023 - 12:16 UTC
This incident affected: Cloud Telephony (Admin Portal).