Verizon European VoIP network outage

Incident Report for LoopUp

Resolved

We're confident that all impacted service areas have been restored. If you experience any new issues, please contact our Support Team: https://support.loopup.com/s/contact-support?language=en_US.
Posted Mar 18, 2025 - 17:01 UTC

Monitoring

The Verizon outage has now been resolved. Our teams are now completing testing to confirm that all impacted service areas are operational. We will continue to monitor and share updates.

If you have any questions or experience any new issues, please contact our Support Team: https://support.loopup.com/s/contact-support?language=en_US.
Posted Mar 18, 2025 - 15:23 UTC

Identified

We have been made aware of a Verizon European VoIP network outage with the potential to impact some Cloud Telephony and Remote Meetings Customers in Europe. Users may experience issues when placing calls to European DDI's/dial-in numbers on relevant routes.

Verizon is actively investigating this issue, and our carriers are prioritizing efforts to resolve it. Our teams have been monitoring the issue and currently assess it to be low impact. We will provide updates as more information becomes available.

If you have any questions, please contact our Support Team: https://support.loopup.com/s/contact-support?language=en_US.
Posted Mar 18, 2025 - 13:09 UTC
This incident affected: Remote Meetings (Audio Conferencing) and Cloud Telephony (Europe, the Middle East and Africa).