Over the weekend, our partner carrier successfully restored services in coordination with the Chinese Ministry of Industry and Information Technology (MIIT). We’ve since confirmed with impacted customers that all services are now operating normally.
If you experience any further issues, please contact us at servicedesk@loopup.com. Thank you for your patience while we worked to resolve this issue.
Posted Apr 22, 2025 - 07:14 UTC
Update
It appears that an upstream carrier has been directly impacted by the enhanced anti-harassment and anti-fraud measures implemented by the Chinese Ministry of Industry and Information Technology (MIIT).
We are continuing to escalate the issue with our partner; however, we do not yet have an estimated time for full service restoration. We appreciate your patience and will share further updates as soon as we have more information.
Posted Apr 16, 2025 - 09:43 UTC
Update
The issues affecting call services in China are ongoing. We’ve been informed that the disruptions are related to anti-harassment and anti-fraud measures implemented by the Chinese Ministry of Industry and Information Technology (MIIT).
Our carrier is actively working with local carriers to restore service as quickly as possible. We’ll continue to provide updates as more information becomes available. Thank you for your continued patience.
Posted Apr 15, 2025 - 16:19 UTC
Identified
We are aware of an issue affecting some of our services in China, where users may experience disruptions when making or receiving calls. The issue has been identified as a downstream network problem, and our carrier is currently working to resolve it.
If you are experiencing any issues, please contact us at servicedesk@loopup.com. We’re sorry for the disruption and appreciate your patience as we work to restore normal service.
Posted Apr 14, 2025 - 09:26 UTC
This incident affected: Cloud Telephony (Asia-Pacific).