The issue affecting calls to certain LoopUp UK Toll Free numbers has been resolved. Normal service has been restored. You can now make calls without any disruptions. Thank you for your patience. For further assistance, contact our Support Team at support@loopup.com.
Posted Jun 28, 2023 - 15:46 UTC
Identified
We have identified an issue that may impact your ability to make calls to certain LoopUp UK Toll Free numbers. Our team is actively investigating this matter and working in collaboration with our downstream carrier to address it urgently. Rest assured, we are fully committed to resolving the issue and minimizing any disruptions to your services.
In the meantime, we have identified an alternate solution for affected users. You can continue to dial into your calls using the following UK Toll Free number: +448002795729. Or, alternatively, you can use the UK Local number: +4403300945859.
We apologize for any inconvenience this may cause and appreciate your patience and understanding. Should you require further assistance, our Support Team is available around the clock and can be reached at support@loopup.com.
Posted Jun 27, 2023 - 09:33 UTC
This incident affected: Remote Meetings (Audio Conferencing).